故乡的食物汪曾祺摘抄:合并起来更完美之二 - 指标公式 - 创幻论坛 -股票、证券、外汇、期货、理财、指标、公式...

来源:百度文库 编辑:偶看新闻 时间:2022/09/29 06:35:41

合并起来更完美之二



这两个买卖公式都是在论坛看到的,一个公式叫“准确买入”,一个公式叫“黄金卖点”,试验了一段时间,准确率非常高,遗憾的是要分开2个副图看,既占用版面空间也非常不便,于是将其合并成一个副图,但是这样一来,“准确买入”的信号就变得非常扁平,几乎看不到。请高手将两公式合并成一副图,还原“准确买入”的黄色和红色清晰的买入信号,令副图更完美。
公式原码如下:

准确买入
K2:=EMA(C,5),COLORFFFF00;
K3:=EMA(C,10),COLORFFFF00;
K5:=EMA(C,30),COLORFFFF00;KK5:=EMA(INDEXC,30),COLORFFFF00;
K6:=2*(K2-K5);K7:=2*(K2-K3);K8:=2*(K7+K6),COLORRED;
STICKLINE(CROSS(K8,0),0,10,8,0) ,COLORRED;
K1:=IF(K8>REF(K8,5) AND K3K21:=IF(K8>REF(K8,7) AND K3K31:=IF(K8>REF(K8,9) AND K3K4:=IF(K8>REF(K8,11) AND K3底部:STICKLINE((K1 OR K21 OR K31 OR K4) AND K8<0 AND K8>REF(K8,1),5,0,8,0) ,COLORYELLOW;

黄金卖点
VAR3:=REF(HIGH,1)*1.1;
VAR4:=HIGH*1.1;
VAR5:=(VAR4*VOL+VAR3*(CAPITAL-VOL))/CAPITAL;
VAR6:=REF(LOW,1)*0.9;
VAR7:=LOW*0.9;
VAR8:=(VAR7*VOL+VAR6*(CAPITAL-VOL))/CAPITAL;
VAR9:=EMA(VAR8,30);
VARA:=EMA(VAR5,30);
VARB:=VARA-2;
VARC:=IF(CLOSE<=VAR9,VARB,VARA);
VARD:=MA(CLOSE,80)-MA(CLOSE,10)/17;
VARE:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
卖出线: SMA(SMA(VARE,3,1),3,1),COLORFF6633  ;
买入线:3*SMA(VARE,3,1)-2*卖出线 ,COLORRED ;
DRAWICON(CROSS(90,买入线),90,2);
顶: STICKLINE(CROSS(90,买入线),100,0,5,0),COLORGREEN ;
黄金点: STICKLINE(SMA(VARE,3,1)>卖出线,SMA(VARE,3,1),卖出线,4,0),COLORYELLOW  ;
0;100;